Intrusion Prevention

HTTP.Proxy.FTP.URL.Buffer.Overflow

Description

It indicates a possible exploit of a buffer overflow vulnerability in Squid.

Affected Products

National Science Foundation Squid Web Proxy 2.4 STABLE3
National Science Foundation Squid Web Proxy 2.4 STABLE2-2
National Science Foundation Squid Web Proxy 2.4 STABLE2
National Science Foundation Squid Web Proxy 2.4 STABLE1

Impact

The execution of arbitrary code on the system.

Recommended Actions

Upgrade to version Squid-2.4.STABLE4 or higher:
http://www.squid-cache.org.

CVE References

CVE-2002-0068