Intrusion Prevention

WWWBoard.Message.Overwrite

Description

It indicates a potentially malicious attempt to overwrite a valid message on WWWBoard 2.0.


wwwboard.pl is a perl script in WWWBoard that processes web discussion board posts. There exists a vulnerability that allows a remote attacker to delete message board articles via specially-crafted arguments.

Affected Products

Any unprotected Matt Wright WWWBoard 2.0 Alpha 2 is vulnerable to the attack.

Impact

Valid posts to the board can be overwritten and erased by a malicious user.

Recommended Actions

Apply appropriate patches or Upgrade the system to the latest non-vulnerable version.